Affichage dynamique de graphiques avec Excel

Cette astuce permet de choisir les courbes affichées dans un graphique et sur lesquelles on veut faire un focus, pour des comparaisons rapides par exemple.

Définir une matrice de données et une liste dynamique des clés de sélection

Créer une liste dynamique pour les clés de sélection (cf. Une liste déroulante dynamique)

Dans une feuille de données Data, créer une matrice de données :

  • col. B : une liste de noms de vendeurs, en ajoutant les 2 clés :
     

    Dans l'exemple, 3 vendeurs :
    - Bastien (ligne 4),
    - Jérôme (ligne 5),
    - Patrice (ligne 6)
     
    auxquels sont ajoutés Tout le monde, (ligne 7) et Moyenne équipe (ligne 8).

  • col. C : les chiffres de ventes de Janvier à Décembre
     
  • C7 à N7 : la somme des ventes du mois
    =SOMME(C4:C6) pour la colonne C par exemple.
     
  • C8 à N8 : la moyenne des ventes du mois
    =MOYENNE(C4:C6) pour la colonne C par exemple.

Nommer la plage de données :

  • sélectionner la plage de données (C4:N8)
  • ruban Formules > Définir un nom
     

    - saisir un nom : _ChiffresVentes
    - la référence automatiquement renseignée est : =BDD!$C$4:$N$8.


Voir la capture d'écran

Préparer la zone des données extraites

Dans la feuille cible, saisir les 3 intitulés Courbe 1 (A14), Courbe 2 (A15) et Courbe 3 (A16)

Mettre en place la liste de choix dans les cellules B14, B15 et B16 (cf. Une liste déroulante dynamique)

Saisir la formule d'extraction pour chacune des cellules C14 à N16 :

  • en C14, saisir la formule : =INDEX(_ChiffresVentes;EQUIV($B14;_Vendeurs;0);0)
     

    EQUIV($B14;_Vendeurs;0) recherche le choix réalisé en B14 dans la plage nommée _Vendeurs et retourne sa position verticale.

    INDEX(_ChiffresVentes;colonne;[ligne]) renvoie la valeur de la plage _ChiffresVentes située à l'intersection d'une colonne et d'une ligne définie.

    $B14, référence semi absolue, permet de recopier la formule sans modification, le numéro de ligne étant recalculé, alors que la colonne reste fixe.

  • recopier cette formule dans les cellules de la plage C14:N16

Voir la capture d'écran

Ajouter le graphique

Sélectionner la plage B14:N16 et ajouter le graphique de comparaison :

  • ruban Insertion > Graphique > Ligne avec marqueurs
  • Ajuster le rendu du graphique :
     

    - échelle des abscisse déclarée sur la plage C3:N3
    - légende placée au-dessous
    - calage pour que les points de données soient au regard des colonnes des mois


Voir la capture d'écran

Usage

Il est maintenant possible de procéder à des comparaisons graphiques en sélectionnant les clés des courbes à afficher.